Catalyst SNMP TWSNMP

TWSNMPを使用したSNMP Polling/Trap通信確認

2019年11月4日



TWSNMPを使用して、クライアントとサーバ間でSNMP通信ができる環境を構築します。
下記のNW構成でサーバからクライアントへのSNMPポーリング及び、クライアントからサーバへのSNMPTrapの送受信を確認します。

各装置でのconfig設定

SNMP Client

CatalystのL2-SWをクライアントとして使用します。

  1. IP設定(default-vlan)
    
    !
    interface Vlan1
    ip address 172.16.1.4 255.255.255.0
    !
    
  2. 通信先のManagerを指定する
  3. 
    !
    snmp-server host 192.168.1.80 version 3 noauth public
    !
    

SNMP Manager

  1. IP設定
    eth1/192.168.1.80
  2. TWSNMPのインストール
    ver.4.4.2
  3. TWSNMP設定
    community名/public

中継用のL3-SW

CatalystのL3-SWを中継SWとして使用します。

  1. SVI設定
    
    Vlan30
    !
    interface Vlan30
    ip address 172.16.1.2 255.255.255.0
    !
    
    
    Vlan50
    !
    interface Vlan50
    ip address 192.168.1.12 255.255.255.0
    !
    
  2. 物理IF設定
    
    !
    interface Fa2/0/1
    switchport access vlan 30
    switchport mode access
    !
    interface Fa2/0/2
    switchport access vlan 50
    switchport mode access
    !
    

SNMP通信確認

SNMP Polling

  1. TWSNMPを立ち上げる
  2. 自動でポーリングによるノード検出を実施
    ポーリングを行うノードを登録するために自動検出します。
    ここでの自動検出はIPレベル監視(Ping疎通)で検出されたノードが検出されます。
    手動でノード登録を行うことも可能です。
    上部メニューから[管理ツール] > [自動発見]を選択して、
    アドレス範囲を指定して[開始]をクリックします。
  3. SNMPポーリングの実施
    検出されたクライアントノードのアイコンを右クリックして、[状態表示]を確認します。
    IPレベルでの通信に問題なければ正常となります。

    続いて[プロパティ]を確認します。
    [インターフェース/ポーリング設定]タブを開きます。
    SNMPポーリングによるインターフェースの監視と、ポーリング内容について設定を行います。IPレベル監視の他にここで監視項目を追加します。それぞれ[自動]をクリックすると、ノードごとに監視できる内容が検出されます。

SNMP Trap

  1. TWSNMPのマップ上で右クリックして[マップ]を選択する
  2. Trap受信ポートに162を指定してOKを選択する
    ※WindowsのFirewallから警告が出ますが、アクセスを許可します。

  3. テストトラップを発生させるためにクライアント端末のIFを論理閉塞する
  4. SNMPManager側のイベント一覧画面に、種類がTrapとして検出できていることを確認手順の②にて、[Trapを受信できません]のようなポップアップが出る場合があります。

    発生する原因は複数あるようですが、私の場合はTWSNMPを再起動することで解消できました。

CATEGORIES & TAGS

Catalyst, SNMP, TWSNMP,

Author:


comment

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

関連記事

むるし

インフラ系エンジニア。備忘録で色々書いていきます。
現在テックキャンプでフルコミット中。

年収訴求

CodeCamp

縛りなしWiFi

%d人のブロガーが「いいね」をつけました。